summaryrefslogtreecommitdiff
path: root/xfconf/Makefile.am
diff options
context:
space:
mode:
authorBrian Tarricone <brian@tarricone.org>2007-09-04 10:54:53 +0000
committerBrian Tarricone <brian@tarricone.org>2007-09-04 10:54:53 +0000
commitafe3cc8b47ef52536d3c7a2b30bb2a627e53a78c (patch)
tree9444a4d8e63e752b74f96b09a1401b8dbc02a21d /xfconf/Makefile.am
parenta73581512e5f856e4eec44ad0c427fc3e9fc144e (diff)
downloadxfconf-afe3cc8b47ef52536d3c7a2b30bb2a627e53a78c.tar.gz
implement pretty much all of XfconfChannel
(Old svn revision: 26708)
Diffstat (limited to 'xfconf/Makefile.am')
-rw-r--r--xfconf/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/xfconf/Makefile.am b/xfconf/Makefile.am
index 644e42b..bb70579 100644
--- a/xfconf/Makefile.am
+++ b/xfconf/Makefile.am
@@ -9,6 +9,8 @@ libxfconfinclude_HEADERS = \
libxfconf_0_la_SOURCES = \
$(libxfconfinclude_HEADERS) \
xfconf-channel.c \
+ xfconf-marshal.c \
+ xfconf-marshal.h \
xfconf-private.h \
xfconf.c \
xfconf-dbus-bindings.h
@@ -37,9 +39,20 @@ pkgconfig_DATA = libxfconf-0.pc
if MAINTAINER_MODE
+xfconf-marshal.h: stamp-xfconf-marshal.h
+ @true
+stamp-xfconf-marshal.h: xfconf-marshal.list Makefile
+ glib-genmarshal --prefix=xfconf_marshal xfconf-marshal.list --header > xfconf-marshal.h
+ echo timestamp > $(@F)
+xfconf-marshal.c: xfconf-marshal.list Makefile
+ echo '#include "xfconf-marshal.h"' > xfconf-marshal.c
+ glib-genmarshal --prefix=xfconf_marshal xfconf-marshal.list --body >> xfconf-marshal.c
+
xfconf-dbus-bindings.h: $(top_srcdir)/common/xfconf-dbus.xml
dbus-binding-tool --mode=glib-client --prefix=xfconf_client $< \
| sed -e 's/org_xfce_Xfconf_/xfconf_client_/g;' \
-e 's/_GUI_/_gui_/g;' > $@
endif
+
+EXTRA_DIST = xfconf-marshal.list