summaryrefslogtreecommitdiff
path: root/xfconf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xfconf/Makefile.am')
-rw-r--r--xfconf/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/xfconf/Makefile.am b/xfconf/Makefile.am
index 3b0bf15..f636564 100644
--- a/xfconf/Makefile.am
+++ b/xfconf/Makefile.am
@@ -54,9 +54,9 @@ BUILT_SOURCES = \
xfconf-dbus-bindings.h
xfconf-dbus-bindings.h: $(top_srcdir)/common/xfconf-dbus.xml Makefile
- dbus-binding-tool --mode=glib-client $< > $(@).tmp
- sed -e 's/^\([[:space:]]\+GValue[[:space:]]\+[^=]\+\).*;$$/\1 = { 0, };/' <$(@).tmp >$@
- -rm -f $(@).tmp
+ $(AM_V_GEN) dbus-binding-tool --mode=glib-client $< > $(@).tmp \
+ && sed -e 's/^\([[:space:]]\+GValue[[:space:]]\+[^=]\+\).*;$$/\1 = { 0, };/' <$(@).tmp >$@ \
+ && rm -f $(@).tmp
# the above fixes a bug in dbus-binding-tool's output
# dbus-binding-tool doesn't initialise GValues to { 0, } properly