summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBrian Tarricone <brian@tarricone.org>2004-09-16 18:19:47 +0000
committerBrian Tarricone <brian@tarricone.org>2004-09-16 18:19:47 +0000
commit9380e446104bd0d9fc67d3f562d32a58bb08f3d6 (patch)
tree1d778a7cc747311bb7d51e1aabb6dd6a5a4647c1 /src/Makefile.am
parentb73b549fe7e948bfdffda54385db828d8749c6ae (diff)
downloadxfdesktop-9380e446104bd0d9fc67d3f562d32a58bb08f3d6.tar.gz
cygwin fixes:
* add -module to modules/menu/Makefile.am and rename library to remove 'lib' prefix * correct the library link order in src/Makefile.am (Old svn revision: 7884)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 92c8bcc9..0d0e785f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -26,13 +26,13 @@ xfdesktop_CFLAGS = \
-DSYSCONFDIR=\"$(sysconfdir)\" \
-DXFCEMODDIR=\"$(libdir)/xfce4/modules\"
-xfdesktop_LDADD = \
- $(top_builddir)/common/libxfdesktop.la \
+# cygwin link order requires this split
+xfdesktop_LDADD = $(top_builddir)/common/libxfdesktop.la
+if BUILD_DESKTOP_MENU
+ xfdesktop_LDADD += $(top_builddir)/common/libxfdesktop-menu.la
+endif
+xfdesktop_LDADD += \
@LIBX11_LDFLAGS@ \
@LIBX11_LIBS@ \
@LIBXFCEGUI4_LIBS@ \
@LIBXFCE4MCS_CLIENT_LIBS@
-
-if BUILD_DESKTOP_MENU
- xfdesktop_LDADD += $(top_builddir)/common/libxfdesktop-menu.la
-endif