summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorroot <root@tinderbox.wearablelab.ml.unisa.edu.au>2007-12-21 00:53:45 +1030
committerroot <root@tinderbox.wearablelab.ml.unisa.edu.au>2007-12-21 01:00:04 +1030
commit4afcc5afa0dc7a1d14e93f18289c4490c9f2decd (patch)
tree59275b6453ed43765ca6334889b26131b80c4bf0 /configure.ac
parentcced740b1e1c8220701e59cec1be04498f851296 (diff)
downloadxorg-app-xinit-4afcc5afa0dc7a1d14e93f18289c4490c9f2decd.tar.gz
Define APPLE for the rest of us
APPLE was only defined when, well on an APPLE. However Makefile.am unconditionally required it. Hence define APPLE to false when we're not on an APPLE. Found by: Tinderbox
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 57def24..df672aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,8 +114,13 @@ if test "x$LAUNCHD" = "xyes" ; then
# A future version of launchd should let us do this cleaner
#XSERVER=\'\`'$(libexecdir)/x11-exec'\`\'
AM_CONDITIONAL(APPLE, true)
- ;;
+ ;;
+ *)
+ AM_CONDITIONAL(APPLE, false)
+ ;;
esac
+else
+ AM_CONDITIONAL(APPLE,false)
fi
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])