summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-01-07 19:21:20 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-01-07 19:21:20 -0800
commitb2b1cc02fdb141cae7ee18034a6ab5d571b7eb6b (patch)
tree3fbd47ca2ecf429075c25dc44d2f629b24fae3d5 /configure.ac
parente6e427bbf6f3c9472dcbff1028fded459c803d6e (diff)
downloadxorg-app-xinit-b2b1cc02fdb141cae7ee18034a6ab5d571b7eb6b.tar.gz
config: replace deprecated AM_CONFIG_HEADER with AC_CONFIG_HEADERS
Regroup AC statements under the Autoconf initialization section. Regroup AM statements under the Automake initialization section. Add missing AC_CONFIG_SRCDIR Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a6ae5ba..ac81293 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,9 +20,14 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xinit], [1.3.0],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xinit])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -32,8 +37,6 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER(config.h)
-
XORG_PROG_RAWCPP
AC_CANONICAL_HOST