summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-06-02 15:23:58 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-06-02 20:05:23 -0400
commit07cc4d60dea2b4c947fed45b082edae4a53b186a (patch)
tree107235b474a814404e7f40bb3e8f9894a91c5173 /configure.ac
parent7888738047e9f1545aa1905b4a2a0654686f49a8 (diff)
downloadxorg-app-xkbcomp-07cc4d60dea2b4c947fed45b082edae4a53b186a.tar.gz
config: add check for yacc to insure it is installed #27973
Unlike other macros AC_PROG_YACC sets the YACC variable to "yacc" as a last resort, even if no programs have been found. Improve error checking by issuing an error message if yacc is not found. The module cannot build anyway. Reported-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c86fcd..3ad342c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,8 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_YACC
+AC_PATH_PROG([YACC_INST], $YACC)
+test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])
AC_PROG_INSTALL