summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-21 20:43:28 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-21 20:43:28 -0200
commitf099da35386cf63d4935ba2613409ff28b3d7ea5 (patch)
tree23c0f8101fabceeef4bc023742a10dd85a4da419 /configure.ac
parent82cebb165b22d5409c9d4d31554a8da0c867e0d3 (diff)
downloadxorg-app-xkbcomp-f099da35386cf63d4935ba2613409ff28b3d7ea5.tar.gz
Correct make distcheck and most gcc and sparse warnings.
Remaining warnings are due to macros that check address or vectors on the stack and auto generated yacc code. Compiled with default flags and also as: % make CFLAGS=-DENTRY_TRACKING_ON -DDEBUG_ON -DASSERTIONS_ON to ensure the "simplification" of code like: foo.c: <hash>define DEBUG_VAR foo_VAR <hash>include "foo.h" ... foo.h: <hash>ifdef DEBUG_VAR_NOT_LOCAL extern <hash>endif int DEBUG_VAR; ... did not change the author's "intended" logic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c11850b..0470334 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,20 +25,28 @@ AC_INIT(xkbcomp,[1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xor
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_YACC
AC_PROG_INSTALL
+XORG_CWARNFLAGS
+
AC_CHECK_FUNCS([strdup strcasecmp])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XKBCOMP, x11 xkbfile)
+XKBCOMP_CFLAGS="$CWARNFLAGS $XKBCOMP_CFLAGS"
AC_SUBST(XKBCOMP_CFLAGS)
AC_SUBST(XKBCOMP_LIBS)
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile])