summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2019-10-11 10:24:30 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2019-10-11 11:18:52 +1000
commite52daf203bb690e33b27514cb8fc76b263e6622a (patch)
tree02ff8fe5b9882fd21172c885b3ab915a66ac4147 /configure.ac
parent400bf493d1840e72dc3bad624707b4934fe5de33 (diff)
downloadxorg-driver-xf86-input-libinput-e52daf203bb690e33b27514cb8fc76b263e6622a.tar.gz
Implement support for scroll button locks
Add a boolean option/property to enable/disable the scroll button lock. Where enabled, the button can be clicked and released as opposed to having to be held down. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba78e97..e19dd03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,17 @@ AC_LINK_IFELSE(
[libinput_have_touch_count=yes]],
[AC_MSG_RESULT([no])
[libinput_have_touch_count=no]])
+
+AC_MSG_CHECKING([if libinput_device_config_scroll_get_button_lock is available])
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[#include <libinput.h>]],
+ [[libinput_device_config_scroll_get_button_lock(NULL)]])],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_LIBINPUT_SCROLL_BUTTON_LOCK, [1],
+ [libinput_device_config_scroll_get_button_lock() is available])
+ [libinput_have_scroll_button_lock=yes]],
+ [AC_MSG_RESULT([no])
+ [libinput_have_scroll_button_lock=no]])
LIBS=$OLD_LIBS
CFLAGS=$OLD_CFLAGS