summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..ecc8597
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,63 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@
+nv_drv_la_LTLIBRARIES = nv_drv.la
+nv_drv_la_LDFLAGS = -module -avoid-version
+nv_drv_ladir = @moduledir@/drivers
+
+nv_drv_la_SOURCES = \
+ nv_const.h \
+ nv_cursor.c \
+ nv_dac.c \
+ nv_dga.c \
+ nv_dma.h \
+ nv_driver.c \
+ nv_hw.c \
+ nv_include.h \
+ nv_local.h \
+ nv_proto.h \
+ nvreg.h \
+ nv_setup.c \
+ nv_shadow.c \
+ nv_type.h \
+ nvvga.h \
+ nv_video.c \
+ nv_xaa.c \
+ riva_const.h \
+ riva_cursor.c \
+ riva_dac.c \
+ riva_dga.c \
+ riva_driver.c \
+ riva_hw.c \
+ riva_hw.h \
+ riva_include.h \
+ riva_local.h \
+ riva_proto.h \
+ riva_setup.c \
+ riva_shadow.c \
+ riva_tbl.h \
+ riva_type.h \
+ riva_xaa.c