summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:26 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:26 -0500
commit87ebfbc56abe16de6f84f559728a40f63d44006a (patch)
tree06a626211c5d3830eb8e6de9ad312038168e074c /Makefile.am
parentd9714f03dde2d2b20fb29d46b44bb253e4954ee0 (diff)
downloadxorg-lib-libXdamage-87ebfbc56abe16de6f84f559728a40f63d44006a.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3279789..358e7f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,3 +31,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xdamage.pc
EXTRA_DIST = xdamage.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog