summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-01-19 08:19:07 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-01-19 08:19:07 -0800
commit0d35761dc39409b70e04dd0786aef6537f92976a (patch)
tree611791d579b70e2dbe186fab62836da620a9d76a /src/Makefile.am
parentc9fa3ec1a7c9847ccf98377b48c674f1d32c635d (diff)
downloadxorg-lib-libXdamage-0d35761dc39409b70e04dd0786aef6537f92976a.tar.gz
Replace deprecated Automake INCLUDES variable with AM_CPPFLAGSbaserock/morph
Excerpt https://lists.gnu.org/archive/html/automake/2012-12/msg00038.html - Support for the long-deprecated INCLUDES variable will be removed altogether in Automake 1.14. The AM_CPPFLAGS variable should be used instead. This variable was deprecated in Automake releases prior to 1.10, which is the current minimum level required to build X. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0027895..969054e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,11 +5,10 @@ libXdamage_la_SOURCES = \
Xdamage.c
libXdamage_la_LIBADD = $(XDAMAGE_LIBS)
-AM_CFLAGS = $(CWARNFLAGS) $(XDAMAGE_CFLAGS)
-
-INCLUDES = -I$(top_srcdir)/include/X11/extensions
-
libXdamage_la_LDFLAGS = -version-number 1:1:0 -no-undefined
+AM_CFLAGS = $(CWARNFLAGS) $(XDAMAGE_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/include/X11/extensions
+
libXdamageincludedir = $(includedir)/X11/extensions
libXdamageinclude_HEADERS = $(top_srcdir)/include/X11/extensions/Xdamage.h