summaryrefslogtreecommitdiff
path: root/sxpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sxpm/Makefile.am')
-rw-r--r--sxpm/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/sxpm/Makefile.am b/sxpm/Makefile.am
index 65388f8..faa192c 100644
--- a/sxpm/Makefile.am
+++ b/sxpm/Makefile.am
@@ -2,7 +2,7 @@ if BUILD_SXPM
bin_PROGRAMS = sxpm
-AM_CFLAGS = $(SXPM_CFLAGS)
+AM_CFLAGS = $(CWARNFLAGS) $(SXPM_CFLAGS)
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
@@ -38,13 +38,13 @@ MAN_SUBSTS = \
SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
- sed $(MAN_SUBSTS) < $< > $@
+ $(AM_V_GEN)sed $(MAN_SUBSTS) < $< > $@
if USE_GETTEXT
noinst_DATA = sxpm.po
sxpm.po: $(sxpm_SOURCES:%=$(srcdir)/%)
- xgettext -c"L10N_Comments" -d sxpm -n $(sxpm_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -c"L10N_Comments" -d sxpm -n $(sxpm_SOURCES:%=$(srcdir)/%)
CLEANFILES += sxpm.po
endif