summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d18b0fe..84a9f4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,7 +86,14 @@ case $host_os in
;;
esac
-AC_HAVE_LIBRARY(ws2_32)
+# Link with winsock if mingw target
+case $host_os in
+ *mingw*)
+ AC_HAVE_LIBRARY(ws2_32)
+ ;;
+ *)
+ ;;
+esac
# Options
AC_ARG_ENABLE(xkb, AS_HELP_STRING([--disable-xkb], [Disable XKB support]),