summaryrefslogtreecommitdiff
path: root/doc/yelp-xsl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/yelp-xsl/Makefile.am')
-rw-r--r--doc/yelp-xsl/Makefile.am28
1 files changed, 9 insertions, 19 deletions
diff --git a/doc/yelp-xsl/Makefile.am b/doc/yelp-xsl/Makefile.am
index 3dd0b55a..61263d98 100644
--- a/doc/yelp-xsl/Makefile.am
+++ b/doc/yelp-xsl/Makefile.am
@@ -13,39 +13,29 @@ xsldoc_xsls = $(filter-out %db2html-suppressed.xsl, \
$(sort $(patsubst ./%, %, \
$(foreach dir,$(xsldoc_dirs), $(wildcard $(dir)/*.xsl)) )) )
xsldoc_base = $(sort $(foreach xsl,$(xsldoc_xsls), $(basename $(notdir $(xsl)))))
+xsldoc_ducks = $(patsubst %, ducks/%.duck, $(xsldoc_base))
xsldoc_pages = $(patsubst %, C/%.page, $(xsldoc_base))
-.PHONY: xsldoc-check-links xsldoc-clean
+.PHONY: xsldoc-clean
if ENABLE_DOC
all: $(xsldoc_pages)
-$(xsldoc_pages): $(xsldoc_xsls) xsldoc-scan.awk xsldoc-scan.xsl
- $(YELP_XSL_AWK) -f "$(srcdir)/xsldoc-scan.awk" "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))" \
- | xsltproc -o "$@" \
+$(xsldoc_ducks): $(xsldoc_xsls) xsldoc-scan.xsl
+ xsltproc -o "$@" \
--stringparam xsldoc.id "$(basename $(notdir $@))" \
- --stringparam xsldoc.xslt_file "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))" \
- "$(srcdir)/xsldoc-scan.xsl" -
-
-C/index.cache: $(xsldoc_pages)
- $(srcdir)/mal2cache "$@" "$(ABS_SRCDIR)/../../xslt/mallard/cache/mal-cache.xsl" C/*.page
+ "$(srcdir)/xsldoc-scan.xsl" \
+ "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))"
-check: xsldoc-check
+$(xsldoc_pages): $(xsldoc_ducks)
+ ducktype -o C/ ducks/*.duck static/*.duck
-xsldoc-check: C/index.cache
- for page in $(wildcard C/*.page); do \
- xsltproc --stringparam xsldoc.cache.file C/index.cache "$(srcdir)/xsldoc-check.xsl" "$$page" || exit 1; \
- done
endif
.PHONY: xsldoc-clean
clean-local: xsldoc-clean
xsldoc-clean:
- rm -f $(xsldoc_pages) C/*.*.page C/*-*.page C/index.cache
+ rm -f C/*.page
EXTRA_DIST = \
- mal2cache \
- xsldoc-check.xsl \
- xsldoc-scan \
- xsldoc-scan.awk \
xsldoc-scan.xsl