summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Hruby <michal.mhr@gmail.com>2012-02-09 16:32:36 +0100
committerMichal Hruby <michal.mhr@gmail.com>2012-02-09 16:32:36 +0100
commite9372f12cdcf774072645ae1f75c3c579ae57a0d (patch)
tree922cd02f0277ab377676db729ed65b4374118b0e /configure.ac
parentbed9fc4862bba98602be99475e5dcd123e0fa521 (diff)
downloadzeitgeist-e9372f12cdcf774072645ae1f75c3c579ae57a0d.tar.gz
Initial stab at transliteration support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83b06deb..cea365cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,30 @@ AC_SUBST(ZEITGEIST_CFLAGS)
AC_SUBST(ZEITGEIST_LIBS)
#################################################
+# Dee-ICU check
+#################################################
+DEE_ICU_REQUIRED=1.0.2
+
+AC_ARG_WITH([dee-icu],
+ AS_HELP_STRING([--with-dee-icu[=@<:@no/auto/yes@:>@]],
+ [Build the FTS extension with dee-icu]),
+ [with_dee_icu=$withval],
+ [with_dee_icu="auto"])
+
+if test "x$with_dee_icu" = "xauto" ; then
+ PKG_CHECK_EXISTS([dee-icu-1.0 >= $DEE_ICU_REQUIRED],
+ with_dee_icu="yes",
+ with_dee_icu="no")
+fi
+
+if test "x$with_dee_icu" = "xyes" ; then
+ PKG_CHECK_MODULES(DEE_ICU, dee-icu-1.0 >= $DEE_ICU_REQUIRED)
+ AC_DEFINE(HAVE_DEE_ICU, 1, [Have dee-icu])
+fi
+
+AM_CONDITIONAL(HAVE_DEE_ICU, test "x$with_dee_icu" = "xyes")
+
+#################################################
# DBus service
#################################################
@@ -88,3 +112,16 @@ else
fi
AC_OUTPUT
+
+cat <<EOF
+
+${PACKAGE}-${VERSION}
+
+ Build Environment
+ Install Prefix: ${prefix}
+
+ Optional dependencies
+ dee-icu: ${with_dee_icu}
+
+EOF
+