summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2014-11-05 15:16:32 +0000
committerSam Thursfield <sam.thursfield@codethink.co.uk>2014-11-05 15:16:32 +0000
commit34f35bba7394345530d4f5124f127e3198ed678d (patch)
tree31e0a8b7080f1a930e08ab563b280bb8cfe803fc /setup.py
parent8a669bb22c1a2bf88ccccf0649aca4cb92198462 (diff)
downloadimport-34f35bba7394345530d4f5124f127e3198ed678d.tar.gz
Add setup.py and move exts/ inside baserockimport package
It's slightly annoying during development, but the exts/ must be inside the package or it would be installed somewhere silly like /usr/lib/python2.7/site-packages/exts.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..0127732
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+# Copyright (C) 2014 Codethink Limited
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+
+'''Setup.py for Baserock Import tool.'''
+
+
+from distutils.core import setup
+
+
+setup(name='baserockimport',
+ classifiers=[
+ 'Development Status :: 2 - Pre-Alpha',
+ 'Environment:: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Software Development :: Embedded Systems',
+ 'Topic :: System :: Archiving :: Packaging',
+ 'Topic :: System :: Software Distribution',
+ ],
+ author='Codethink Limited',
+ author_email='baserock-dev@baserock.org',
+ url='http://www.baserock.org',
+ scripts=['baserock-import.py'],
+ packages=['baserockimport'],
+ package_data={
+ 'baserockimport': [
+ 'exts/*',
+ ]
+ },
+)