summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Silverstone <daniel.silverstone@codethink.co.uk>2012-09-21 17:13:04 +0100
committerDaniel Silverstone <daniel.silverstone@codethink.co.uk>2012-09-24 15:03:55 +0100
commita7f8b1b63a97c66aea6f39342313d7a5b919cfa7 (patch)
tree967235881352d2ae3c8f14fa026abdb968755841 /setup.py
parentbf479d5b735b31fde4ecfbfbca4d1217a64f8403 (diff)
downloadlorry-a7f8b1b63a97c66aea6f39342313d7a5b919cfa7.tar.gz
Fix up Lorry to expect repositories to be bare.
This patch makes Lorry always create bare repositories where it can (Note that it cannot for CVS imports) and to create tarballs of bare repositories (if not disabled) which will be more efficient than bundles for creation and cloning. We may be able to disable bundles later.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cc5bde5..63bd431 100644
--- a/setup.py
+++ b/setup.py
@@ -26,8 +26,6 @@ import os
import shutil
import subprocess
-import morphlib
-
class GenerateManpage(build):
@@ -46,6 +44,7 @@ class Clean(clean):
clean_files = [
'.coverage',
'build',
+ 'lorry.1'
]
clean_globs = [
'*/*.py[co]',
@@ -86,7 +85,7 @@ FIXME
author='Baserock',
author_email='baserock-dev@baserock.org',
url='http://wiki.baserock.org/',
- scripts=['lorry'],
+ scripts=['lorry', 'lorry.tar-importer'],
data_files=[('share/man/man1', glob.glob('*.[1-8]'))],
cmdclass={
'build': GenerateManpage,