summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2016-03-31 11:44:02 +0100
committerSam Thursfield <sam.thursfield@codethink.co.uk>2016-03-31 11:44:02 +0100
commitffdfee2c78462b53ae9af1e414cc71a8734e606a (patch)
treea191f4c60261e974a5124bf7207e6c19c0d3356f /setup.py
parente36043737201a645897d366ba0eb44e91748d16e (diff)
downloadmorph-ffdfee2c78462b53ae9af1e414cc71a8734e606a.tar.gz
Fix issues running tests outside a Baserock system
Warn if 'Yarn' isn't available, since this means most tests don't run. Also fix some issue with missing .coverage file that I hit. Change-Id: I675354799bbdefe1ced0f5a0c5221b103de29a1c
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6d0bbcab..29e52d12 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-# Copyright (C) 2011,2014-2015 Codethink Limited
+# Copyright (C) 2011,2014-2016 Codethink Limited
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -128,7 +128,10 @@ class Check(Command):
subprocess.check_call(['python', '-m', 'CoverageTestRunner',
'--ignore-missing-from=without-test-modules',
'morphlib', 'distbuild'])
- os.remove('.coverage')
+ try:
+ os.remove('.coverage')
+ except OSError:
+ pass
setup(name='morph',