summaryrefslogtreecommitdiff
path: root/ACE/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-06-12 22:01:53 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-06-12 22:01:53 +0000
commit77d4bcffb8c6cb713005a96240c012e30d7f4256 (patch)
treeb9615cdc7d59e2c88ed0ea0132863c112b0f8534 /ACE/configure.ac
parentfa19e9520ca010f9770600dd846c89582afb23db (diff)
downloadATCD-77d4bcffb8c6cb713005a96240c012e30d7f4256.tar.gz
ChangeLogTag: Thu Jun 12 21:57:33 UTC 2008 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'ACE/configure.ac')
-rw-r--r--ACE/configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/ACE/configure.ac b/ACE/configure.ac
index e7880b92df1..afdd43a7a6c 100644
--- a/ACE/configure.ac
+++ b/ACE/configure.ac
@@ -2822,35 +2822,6 @@ dnl END OUTER REQUIRE PRAGMA #########################################
])
-dnl Check if platform supports template specialization
-ACE_CACHE_CHECK([for template specialization],
- [ace_cv_feature_cxx_template_specialization],[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- template <class T>
- class Foo
- {
- public:
- Foo(T bar) : bar_(bar) {};
- private:
- T bar_;
- };
-
- class Foo<int>
- {
- public:
- Foo(int bar) : bar_(bar + 1) {};
- private:
- int bar_;
- };
- ]],[[
- Foo<int> foo(11);
- ]])],[
- ace_cv_feature_cxx_template_specialization=yes
- ],[
- ace_cv_feature_cxx_template_specialization=no
- ])
- ],[AC_DEFINE([ACE_HAS_TEMPLATE_SPECIALIZATION])],)
-
dnl Check if platform supports template typedefs
ACE_CACHE_CHECK([for template typedefs],
[ace_cv_feature_posix_template_typedefs],[