summaryrefslogtreecommitdiff
path: root/TAO/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-12-27 23:36:50 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-12-27 23:36:50 +0000
commitac7f6c21bd2faa8c5400ead819b1f79baddce053 (patch)
tree14ba9a1ff0a0c7cece8631d1fe4da36a4fabe20d /TAO/Makefile.am
parent9331163cd68762d3cdf85f10cdc6132fac7f9643 (diff)
downloadATCD-ac7f6c21bd2faa8c5400ead819b1f79baddce053.tar.gz
ChangeLogTag: Tue Dec 27 15:33:28 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/Makefile.am')
-rw-r--r--TAO/Makefile.am60
1 files changed, 45 insertions, 15 deletions
diff --git a/TAO/Makefile.am b/TAO/Makefile.am
index c9bf23fb7a4..3a9628ad79e 100644
--- a/TAO/Makefile.am
+++ b/TAO/Makefile.am
@@ -1,26 +1,56 @@
-## Process this file with automake to create Makefile.in
+##---------------------------------------------------------------------------
+## $Id$
+##
+## Top-level Makefile for TAO
##
-## $Id$
+##---------------------------------------------------------------------------
+
##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
+## Process this file with automake to create Makefile.in
##
-## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+
+AUTOMAKE_OPTIONS = foreign
+
+ACLOCAL = @ACLOCAL@
+ACLOCAL_AMFLAGS = -I m4 -I ../m4
SUBDIRS = \
TAO_IDL \
tao \
- orbsvcs \
- examples \
+ orbsvcs \
+ examples \
docs \
- performance-tests \
- interop-tests \
- tests \
- utils
+ performance-tests \
+ interop-tests \
+ utils
+## For some reason, automake doesn't include acconfig.h in the distribution
+EXTRA_DIST = \
+ PROBLEM-REPORT-FORM \
+ VERSION \
+ COPYING.sun \
+ LICENSE.sun \
+ README.sun
-ACLOCAL = @ACLOCAL@
-ACLOCAL_AMFLAGS = -I m4 -I ../m4
-AUTOMAKE_OPTIONS = foreign
+## release:
+## $(MAKE) dist distdir=$(PACKAGE)$(VERSION)
+release:
+ $(MAKE) dist
+
+## Directories to include in the distribution but which I am too lazy to
+## create Makefile.am files for. A Makefile.am for these directories isn't
+## needed anyway.
+TAO_EXTRA_DIST = docs
+
+dist-hook:
+ (cd $(top_srcdir); tar cf - $(TAO_EXTRA_DIST)) | (cd $(distdir); \
+ tar xfBp -)
+ list=`find $(distdir) -type d -name CVS -print`; for p in $$list; do \
+ rm -rf $$p; \
+ done
+## Clean up some additional files/directories possibly created during
+## the configure script tests.
+clean-local:
+ -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations