summaryrefslogtreecommitdiff
path: root/TAO/examples/Advanced/ch_3/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-09-23 01:22:32 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-09-23 01:22:32 +0000
commit1c549314a0b8a077329e8bd3c0843a7a8969b05e (patch)
tree4f08d1620878ec031f5a110b7eaa8f7a30e25195 /TAO/examples/Advanced/ch_3/Makefile.am
parent0e7da4cdc504396b7c8504aa8b6776bdf598694d (diff)
downloadATCD-1c549314a0b8a077329e8bd3c0843a7a8969b05e.tar.gz
ChangeLogTag: Thu Sep 22 14:03:11 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/examples/Advanced/ch_3/Makefile.am')
-rw-r--r--TAO/examples/Advanced/ch_3/Makefile.am114
1 files changed, 114 insertions, 0 deletions
diff --git a/TAO/examples/Advanced/ch_3/Makefile.am b/TAO/examples/Advanced/ch_3/Makefile.am
new file mode 100644
index 00000000000..014f7165a1f
--- /dev/null
+++ b/TAO/examples/Advanced/ch_3/Makefile.am
@@ -0,0 +1,114 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Advanced_Ch_3_Idl.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES = \
+ timeC.cpp \
+ timeC.h \
+ timeC.inl \
+ timeS.cpp \
+ timeS.h \
+ timeS.inl \
+ timeS_T.cpp \
+ timeS_T.h \
+ timeS_T.inl
+
+CLEANFILES = \
+ time-stamp \
+ timeC.cpp \
+ timeC.h \
+ timeC.inl \
+ timeS.cpp \
+ timeS.h \
+ timeS.inl \
+ timeS_T.cpp \
+ timeS_T.h \
+ timeS_T.inl
+
+timeC.cpp timeC.h timeC.inl timeS.cpp timeS.h timeS.inl timeS_T.cpp timeS_T.h timeS_T.inl: time-stamp
+
+time-stamp: $(srcdir)/time.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/time.idl
+ @touch $@
+
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Advanced_Ch_3_Client.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+client_SOURCES = \
+ client.cpp \
+ timeC.cpp \
+ server.h
+
+client_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Makefile.Advanced_Ch_3_Server.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+server_SOURCES = \
+ server.cpp \
+ timeC.cpp \
+ timeS.cpp \
+ server.h
+
+server_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB