summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-08-17 06:42:10 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-08-17 06:42:10 +0000
commit46d5f5b104d3259b294358e287c0705d54459dad (patch)
tree396f346d283258f64e41a2e73cca957775cc85c3 /TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am
parentb16dd96d261e47f8671305483673aee7f189db81 (diff)
downloadATCD-46d5f5b104d3259b294358e287c0705d54459dad.tar.gz
ChangeLogTag: Mon Aug 16 23:35:00 2004 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am b/TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am
index 7165f405716..1d6ff7869d7 100644
--- a/TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am
+++ b/TAO/orbsvcs/tests/AVStreams/Pluggable_Flow_Protocol/Makefile.am
@@ -14,7 +14,8 @@ receiver_CPPFLAGS = \
-I$(ACE_BUILDDIR) \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
- -I$(TAO_ROOT)/orbsvcs/orbsvcs
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
receiver_SOURCES = \
receiver.cpp \
@@ -34,7 +35,6 @@ receiver_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-
## Makefile.AVS_Pluggable_Flow_Protocol_Send.am
noinst_PROGRAMS += sender
@@ -44,7 +44,8 @@ sender_CPPFLAGS = \
-I$(ACE_BUILDDIR) \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
- -I$(TAO_ROOT)/orbsvcs/orbsvcs
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
sender_SOURCES = \
sender.cpp \
@@ -64,7 +65,6 @@ sender_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-
## Makefile.AVS_Pluggable_Flow_Protocol_Ts.am
noinst_LTLIBRARIES = libTAO_TS.la
@@ -74,12 +74,16 @@ libTAO_TS_la_CPPFLAGS = \
-I$(ACE_BUILDDIR) \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
- -I$(TAO_ROOT)/orbsvcs/orbsvcs \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
-DTAO_TS_BUILD_DLL
libTAO_TS_la_SOURCES = \
TimeStamp.cpp
+libTAO_TS_la_LDFLAGS = \
+ -version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
+
libTAO_TS_la_LIBADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
@@ -97,7 +101,6 @@ libTAO_TS_la_LIBADD = \
noinst_HEADERS = \
TimeStamp.h
-
## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core