summaryrefslogtreecommitdiff
path: root/TAO/tests/Bug_3321_Regression/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-05-09 18:37:19 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-05-09 18:37:19 +0000
commit588a3fba9b83388465b418ceb9145cab346b118c (patch)
treece4b9a94ea4bf41db97b33df351e606266ef1cc3 /TAO/tests/Bug_3321_Regression/Makefile.am
parent88a02eacea34dcf7adfd20dee5b8c4a198c854c8 (diff)
downloadATCD-588a3fba9b83388465b418ceb9145cab346b118c.tar.gz
ChangeLogTag: Fri May 9 18:26:24 UTC 2008 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/tests/Bug_3321_Regression/Makefile.am')
-rw-r--r--TAO/tests/Bug_3321_Regression/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/TAO/tests/Bug_3321_Regression/Makefile.am b/TAO/tests/Bug_3321_Regression/Makefile.am
new file mode 100644
index 00000000000..e540e000dd3
--- /dev/null
+++ b/TAO/tests/Bug_3321_Regression/Makefile.am
@@ -0,0 +1,48 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.Bug_3321_Regression.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS = server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+server_SOURCES = \
+ main.cpp
+
+server_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB