summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-12-27 20:43:27 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-12-27 20:43:27 +0000
commit0f0fb08115c2362b352b5371c9df223d22164371 (patch)
treef80811721abfdd509170d268e1e8a3b98a9b9c5e /configure.ac
parentcc9eeac8b32f3026656e18eb3104b4db27f94ac1 (diff)
downloadATCD-0f0fb08115c2362b352b5371c9df223d22164371.tar.gz
ChangeLogTag: Tue Dec 27 12:41:00 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 802ec3008a6..6a53a42f431 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1140,6 +1140,12 @@ dnl AC_CHECK_TYPE([off64_t],[long long])
dnl Specific typedef checks
dnl TODO: Check whether these typedefs can be defined somewhere else.
+AC_CHECK_TYPE([cpu_set_t],
+ [AC_DEFINE([ACE_HAS_CPU_SET_T], 1,
+ [Define to 1 if the system has the type `cpu_set_t'.])],
+ [],
+ [#include <sys/types.h>])
+
AC_CHECK_TYPE([idtype_t],
[AC_DEFINE([ACE_HAS_IDTYPE_T], 1,
[Define to 1 if the system has the type `idtype_t'.])],
@@ -4291,6 +4297,9 @@ dnl Check for Unix98 pthreads extensions
ACE_CHECK_HAS_FUNCS(pthread_getconcurrency pthread_setconcurrency)
ACE_CHECK_HAS_FUNCS(pthread_attr_setcreatesuspend_np)
+ ACE_CHECK_HAS_FUNCS(pthread_getaffinity_np pthread_setaffinity_np)
+ ACE_CHECK_HAS_FUNCS(sched_getaffinity, sched_setaffinity)
+
AC_CHECK_FUNC([pthread_rwlock_init],,)
AC_CHECK_FUNC([pthread_rwlock_destroy],,)
AC_CHECK_FUNC([pthread_rwlock_rdlock],,)