summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-01-17 07:18:02 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-01-17 07:18:02 +0000
commitd117b708bb9789139816e754581230e93a7ff83d (patch)
treed6bd174d7b743126ab7cb3056fc52175b839bbe0 /configure.ac
parentbf3e7b37a00e6b92022ca8925ca8a07cf0caeb9c (diff)
downloadATCD-d117b708bb9789139816e754581230e93a7ff83d.tar.gz
ChangeLogTag: Sun Jan 16 23:26:58 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 21 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 7c049a3de83..3780ffd204f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -539,6 +539,8 @@ ACE_CHECK_LACKS_HEADERS(errno.h)
ACE_CHECK_LACKS_HEADERS(fcntl.h)
+ACE_CHECK_HAS_HEADERS(pthread_np.h)
+
ACE_CHECK_LACKS_HEADERS(search.h)
ACE_CHECK_HAS_HEADERS(select.h)
@@ -1266,28 +1268,25 @@ dnl structure we are testing for.
dnl Thanks to Konstantinos Margaritis <kmargar@cc.uoa.gr> for pointing out
dnl that struct siginfo_t may also be defined in signal.h
-ACE_CACHE_CHECK([for struct siginfo_t],[ace_cv_struct_siginfo_t],
- [
- dnl Since we are checking for siginfo_t in more than one header
- dnl we can't use the ACE_CHECK_STRUCT macro so we have to do things
- dnl manually.
- ACE_TRY_COMPILE_STRUCT([siginfo_t],[siginfo.h],
- [
- ace_cv_struct_siginfo_t=yes
- ],
- [
- ACE_TRY_COMPILE_STRUCT([siginfo_t],[signal.h],
- [
- ace_cv_struct_siginfo_t=yes
- ],
- [
- ace_cv_struct_siginfo_t=no
- ])
- ])
- ],
- [
- AC_DEFINE([ACE_HAS_SIGINFO_T])
- ],)
+AC_CHECK_TYPE([siginfo_t],
+ [AC_DEFINE([ACE_HAS_SIGINFO_T], 1,
+ [Define to 1 if the system has the type `siginfo_t'.])],
+ [],
+ [#include <signal.h>
+#ifndef ACE_LACKS_SIGINFO_H
+#include <siginfo.h>
+#endif])
+
+if test "$ac_cv_type_siginfo_t" = yes; then
+ AC_CHECK_MEMBER([siginfo_t.si_addr],
+ [],
+ [AC_DEFINE([ACE_LACKS_SI_ADDR], 1,
+ [Define to 1 if `si_addr' is not a member of `siginfo_t'.])],
+ [#include <signal.h>
+#ifndef ACE_LACKS_SIGINFO_H
+#include <siginfo.h>
+#endif])
+fi
dnl Some platforms need to include sys/types.h before sys/socket.h
dnl in order for struct msghdr to work.