summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-05-09 23:37:55 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-05-09 23:37:55 +0000
commit2e4e9c56c7b61b33594f989157c6fd843d796690 (patch)
treed49ca0eba827ccbb47dc7dbe797f7cb1b97d88e4 /configure.in
parentd579a1a258d627d4e755f424b3259115acb28d07 (diff)
downloadATCD-2e4e9c56c7b61b33594f989157c6fd843d796690.tar.gz
Added support/tests for ACE_LACKS_CHAR_RIGHT_SHIFTS and
ACE_LACKS_CHAR_STAR_RIGHT_SHIFTS.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 52 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cf63bf95f1b..bdc03b11319 100644
--- a/configure.in
+++ b/configure.in
@@ -1078,6 +1078,7 @@ AC_CHECK_HEADER(sys/procfs.h, dnl
[
],
[
+ dnl If ace_has_procfs_conflict = no then define ACE_HAS_PROC_FS.
AC_DEFINE(ACE_HAS_PROC_FS)
])
],)
@@ -2237,6 +2238,56 @@ fi dnl test "$cross_compiling" != yes
dnl Other checks
+
+dnl Check for istream operator>> for char, unsigned char and signed char
+ACE_CACHE_CHECK(for istream operator>> for char types,
+ ace_cv_feature_char_right_shifts,
+ [
+ AC_TRY_COMPILE([
+#include <iostream.h>
+ ],
+ [
+unsigned char a = 0;
+cin >> a;
+
+#ifndef ACE_LACKS_SIGNED_CHAR
+signed char b = 0;
+cin >> b;
+#endif
+ ],
+ [
+ ace_cv_feature_char_right_shifts=yes
+ ],
+ [
+ ace_cv_feature_char_right_shifts=no
+ ])
+ ], , AC_DEFINE(ACE_LACKS_CHAR_RIGHT_SHIFTS))
+
+
+dnl Check for istream operator>> for char *, unsigned char * and signed char *
+ACE_CACHE_CHECK(for istream operator>> for char * types,
+ ace_cv_feature_char_ptr_right_shifts,
+ [
+ AC_TRY_COMPILE([
+#include <iostream.h>
+ ],
+ [
+unsigned char * a = 0;
+cin >> a;
+
+#ifndef ACE_LACKS_SIGNED_CHAR
+signed char * b = 0;
+cin >> b;
+#endif
+ ],
+ [
+ ace_cv_feature_char_ptr_right_shifts=yes
+ ],
+ [
+ ace_cv_feature_char_ptr_right_shifts=no
+ ])
+ ], , AC_DEFINE(ACE_LACKS_CHAR_STAR_RIGHT_SHIFTS))
+
dnl Check if we have working C++ explicit template destructors
dnl Thanks to Nanbor Wang <nanbor@cs.wustl.edu> for providing this test.
ACE_CACHE_CHECK(for working C++ explicit template destructors,
@@ -5986,7 +6037,7 @@ WE_HAVE_PTHREADS_D4
#include <pthread.h>
#include <stdio.h>
-#ifdef __CPLUSPLUS
+#ifdef __cplusplus
extern "C"
#endif
void *