summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2000-06-15 01:04:47 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2000-06-15 01:04:47 +0000
commit4a0afe8d9d9c190cec96e7aa8ebdd2f9f3b23be8 (patch)
tree5676b12361f56ab26969d9ffee31f64a3b22fa67 /configure.in
parentf51a369952a5cd00927437bd6a927c9c92abc220 (diff)
downloadATCD-4a0afe8d9d9c190cec96e7aa8ebdd2f9f3b23be8.tar.gz
ChangeLogTag:Wed Jun 14 17:54:18 2000 Ossama Othman <ossama@uci.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in173
1 files changed, 135 insertions, 38 deletions
diff --git a/configure.in b/configure.in
index f057b744a5e..ece1e13798d 100644
--- a/configure.in
+++ b/configure.in
@@ -4499,38 +4499,129 @@ ${ace_pthread_key_create}(0, ace_destructor);
],)
]) dnl ACE_CONVERT_WARNINGS_TO_ERRORS
-dnl FIXME: These tests look sloppy to me. -Ossama
- AC_CACHE_CHECK(for minimum thread priority,
- ace_cv_lib_pthread_pthread_min_priority,[
- ace_cv_lib_pthread_pthread_min_priority=0
- AC_EGREP_HEADER(PTHREAD_MIN_PRIORITY, pthread.h,
- ace_cv_lib_pthread_pthread_min_priority=PTHREAD_MIN_PRIORITY)
- AC_EGREP_HEADER(PX_PRIO_MIN, pthread.h,
- ace_cv_lib_pthread_pthread_min_priority=PX_PRIO_MIN)
- ])
- AC_DEFINE_UNQUOTED(ACE_THREAD_MIN_PRIORITY,
- $ace_cv_lib_pthread_pthread_min_priority)
-
- AC_CACHE_CHECK(for maximum thread priority,
- ace_cv_lib_pthread_pthread_max_priority,[
- ace_cv_lib_pthread_pthread_max_priority=99
- case "$target" in
- *linux*)
- if test "$ac_cv_func_pthread_sigmask" = yes; then
- ace_cv_lib_pthread_pthread_max_priority=99
- else
- ace_cv_lib_pthread_pthread_max_priority=32
- fi
- ;;
- *)
- esac
- AC_EGREP_HEADER(PTHREAD_MAX_PRIORITY, pthread.h,
- ace_cv_lib_pthread_pthread_max_priority=PTHREAD_MAX_PRIORITY)
- AC_EGREP_HEADER(PX_PRIO_MAX, pthread.h,
- ace_cv_lib_pthread_pthread_max_priority=PX_PRIO_MAX)
- ])
- AC_DEFINE_UNQUOTED(ACE_THREAD_MAX_PRIORITY,
- $ace_cv_lib_pthread_pthread_max_priority)
+
+AC_CHECK_FUNC([sched_get_priority_min],
+ [
+ dnl Do nothing
+ ],
+ [
+ AC_EGREP_CPP([ace_has_pthread_min_priority],,
+ [
+dnl Check PTHREAD_MIN_PRIORITY is a macro.
+#include <pthread.h>
+#ifdef PTHREAD_MIN_PRIORITY
+ ace_has_pthread_min_priority
+#endif /* PTHREAD_MIN_PRIORITY */
+ ],
+ [
+ dnl Since we PTHREAD_MAX_PRIORITY, denote that PX_PRIO_MAX should
+ dnl not be used.
+ ace_has_px_prio_min=no
+ ],
+ [
+ dnl Check if PTHREAD_MIN_PRIORITY is not a macro.
+ AC_EGREP_HEADER([PTHREAD_MIN_PRIORITY], [pthread.h],
+ [
+ dnl Since we PTHREAD_MAX_PRIORITY, denote that PX_PRIO_MAX should
+ dnl not be used.
+ ace_has_px_prio_min=no
+ ],
+ [
+ dnl PTHREAD_MIN_PRIORITY doesn't appear to be defined, so
+ dnl check if the platform defines PX_PRIO_MIN, instead.
+
+ dnl Check if PX_PRIO_MIN is defined.
+ AC_EGREP_CPP([ace_has_px_prio_min],
+ [
+ dnl Check PX_PRIO_MIN is a macro.
+#include <pthread.h>
+#ifdef PX_PRIO_MIN
+ ace_has_px_prio_min
+#endif /* PX_PRIO_MIN */
+ ],
+ [
+ ace_has_px_prio_min=yes
+ ],
+ [
+ dnl Check if PX_PRIO_MIN is not a macro.
+ AC_EGREP_HEADER([PX_PRIO_MIN], [pthread.h],
+ [
+ ace_has_px_prio_min=yes
+ ],
+ [
+ ace_has_px_prio_min=no
+ ])
+ ])
+ ])
+ ])
+ ])
+
+ if test "$ace_has_px_prio_min" = yes; then
+ AC_DEFINE(PTHREAD_MIN_PRIORITY,
+ PX_PRIO_MIN,
+ [Minimum thread priority])
+ fi
+
+AC_CHECK_FUNC([sched_get_priority_max],
+ [
+ dnl Do nothing
+ ],
+ [
+ AC_EGREP_CPP([ace_has_pthread_max_priority],
+ [
+dnl Check PTHREAD_MAX_PRIORITY is a macro.
+#include <pthread.h>
+#ifdef PTHREAD_MAX_PRIORITY
+ ace_has_pthread_max_priority
+#endif /* PTHREAD_MAX_PRIORITY */
+ ],
+ [
+ dnl Since we PTHREAD_MAX_PRIORITY, denote that PX_PRIO_MAX should
+ dnl not be used.
+ ace_has_px_prio_max=no
+ ],
+ [
+ dnl Check if PTHREAD_MAX_PRIORITY is not a macro.
+ AC_EGREP_HEADER([PTHREAD_MAX_PRIORITY], [pthread.h],
+ [
+ dnl Since we PTHREAD_MAX_PRIORITY, denote that PX_PRIO_MAX should
+ dnl not be used.
+ ace_has_px_prio_max=no
+ ],
+ [
+ dnl PTHREAD_MAX_PRIORITY doesn't appear to be defined, so
+ dnl check if the platform defines PX_PRIO_MAX, instead.
+
+ dnl Check if PX_PRIO_MAX is defined.
+ AC_EGREP_CPP([ace_has_px_prio_max],
+ [
+ dnl Check PX_PRIO_MIN is a macro.
+#include <pthread.h>
+#ifdef PX_PRIO_MAX
+ ace_has_px_prio_max
+#endif /* PX_PRIO_MAX */
+ ],
+ [
+ ace_has_px_prio_max=yes
+ ],
+ [
+ dnl Check if PX_PRIO_MAX is not a macro.
+ AC_EGREP_HEADER([PX_PRIO_MAX], [pthread.h],
+ [
+ ace_has_px_prio_max=yes
+ ],
+ [
+ ace_has_px_prio_max=no
+ ])
+ ])
+ ])
+ ])
+ ])
+ if test "$ace_has_px_prio_max" = yes; then
+ AC_DEFINE(PTHREAD_MAX_PRIORITY,
+ PX_PRIO_MAX,
+ [Maximum thread priority])
+ fi
fi dnl test "$ace_has_pthreads" = yes
@@ -7253,8 +7344,8 @@ the file \`ACE-INSTALL.html'.
])
])
-dnl Check for ACE iostream support
-ACE_CACHE_CHECK(for ACE iostream support,
+dnl Check for ACE_IOStream support
+ACE_CACHE_CHECK(for ACE_IOStream support,
ace_cv_feature_ace_iostream,
[
dnl We want an empty ace/config.h to prevent multiple defines
@@ -7331,6 +7422,10 @@ ACE_CACHE_CHECK(if ACE needs minimum iostream header inclusion,
])
], AC_DEFINE(ACE_HAS_MINIMUM_IOSTREAMH_INCLUSION),)
+dnl @@ I don't think that this test is correct. The only way I could
+dnl get ACE_Addr::sap_any to work was to explicitly cast it to the
+dnl a constant reference of the derived type.
+dnl -Ossama
dnl Check if compiler can't handle the static ACE_Addr::sap_any construct
ACE_CACHE_CHECK(for ACE_addr::sap_any support,
ace_cv_lib_sap_any_support,
@@ -7346,10 +7441,10 @@ ACE_CACHE_CHECK(for ACE_addr::sap_any support,
typedef ACE_UINT64_TYPEDEF ACE_UINT64;
#endif /* ACE_UINT64_TYPEDEF */
-#include "ace/Addr.cpp"
+#include "ace/FILE_Addr.h"
],
[
- int a=0; a += 1;
+ ACE_FILE_Addr ace_file ((const ACE_FILE_Addr &) ACE_Addr::sap_any);
],
[
ace_cv_lib_sap_any_support=yes
@@ -7364,10 +7459,10 @@ ACE_CACHE_CHECK(for ACE_addr::sap_any support,
#endif /* ACE_UINT64_TYPEDEF */
#define ACE_HAS_BROKEN_SAP_ANY
-#include "ace/Addr.cpp"
+#include "ace/FILE_Addr.h"
],
[
- int a=0; a += 1;
+ ACE_FILE_Addr ace_file ((const ACE_FILE_Addr &) ACE_Addr::sap_any);
],
[
ace_cv_lib_sap_any_support=no
@@ -7478,6 +7573,8 @@ dnl created first.
AC_OUTPUT([
Makefile
ace-config
+ ace-config.1
+ aceConf.sh
ace/Makefile
apps/Makefile
apps/gperf/Makefile