summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-03-15 01:57:00 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-03-15 01:57:00 +0000
commit52250fa17a42a2a78d430549f616fcac42387a19 (patch)
tree7f306a32618c931024551e72b6fad6164f76c5c5 /configure.in
parentff2e60e7085f54ea0db2704080685a13ab59dd84 (diff)
downloadATCD-52250fa17a42a2a78d430549f616fcac42387a19.tar.gz
* configure.in: Added real-time support library `-lrt' check to
asynchronous IO functions/libraries checks. GNU glibc 2.1 adds support for the POSIX 1b real-time specification in the library `librt'. The POSIX asynchronous IO functions may be found in that library. Currently, `-lpthread' must also be linked to in addition to `-lrt'.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6b58261789e..3076d4fe76f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl $Id$
-AC_REVISION($Revision 0.53 $)dnl
+AC_REVISION($Revision 0.54 $)dnl
dnl
dnl An autoconf script to automatically configure ACE.
@@ -925,12 +925,22 @@ AC_CHECK_FUNC(t_accept, , dnl
AC_CHECK_LIB(tli, t_accept, ,
AC_CHECK_LIB(nsl, t_accept, ,ace_has_tli_funcs=no)))))
+dnl Check for all of the things we need to compile and link threads
+dnl properly.
+if test "$ace_user_enable_threads" = yes; then
+ ACE_CHECK_THREADS
+fi dnl test "$ace_user_enable_threads" = yes
+
dnl Asynchronous IO library check
dnl Some platforms, such as Solaris puts aio_read in -lposix4, for example.
+dnl In some cases, the thread library must be linked to in addition to the
+dnl real-time support library. As such, make sure these checks are done
+dnl after the thread library checks.
ace_has_aio_funcs=yes
AC_CHECK_FUNC(aio_read, , dnl
AC_CHECK_LIB(aio, aio_read, ,
- AC_CHECK_LIB(posix4, aio_read, , ace_has_aio_funcs=no)))
+ AC_CHECK_LIB(posix4, aio_read, ,
+ AC_CHECK_LIB(rt, aio_read, , ace_has_aio_funcs=no)))
dnl Check for all of the things we need to compile and link threads
dnl properly.