summaryrefslogtreecommitdiff
path: root/ACE/examples/TMCast/Member/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/examples/TMCast/Member/Makefile.am')
-rw-r--r--ACE/examples/TMCast/Member/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/ACE/examples/TMCast/Member/Makefile.am b/ACE/examples/TMCast/Member/Makefile.am
new file mode 100644
index 00000000000..fe970a85ef5
--- /dev/null
+++ b/ACE/examples/TMCast/Member/Makefile.am
@@ -0,0 +1,45 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.Member.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS = member
+
+member_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/protocols
+
+member_SOURCES = \
+ member.cpp
+
+member_LDADD = \
+ $(ACE_BUILDDIR)/protocols/ace/TMCast/libACE_TMCast.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB