summaryrefslogtreecommitdiff
path: root/TAO/examples/AMH/Sink_Server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/AMH/Sink_Server/Makefile.am')
-rw-r--r--TAO/examples/AMH/Sink_Server/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/TAO/examples/AMH/Sink_Server/Makefile.am b/TAO/examples/AMH/Sink_Server/Makefile.am
index 26c05fd1362..858aba8073b 100644
--- a/TAO/examples/AMH/Sink_Server/Makefile.am
+++ b/TAO/examples/AMH/Sink_Server/Makefile.am
@@ -57,6 +57,7 @@ endif BUILD_CORBA_MESSAGING
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -84,6 +85,7 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
@@ -91,6 +93,7 @@ endif BUILD_CORBA_MESSAGING
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += mt_server
@@ -125,6 +128,7 @@ mt_server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
@@ -132,6 +136,7 @@ endif BUILD_CORBA_MESSAGING
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += st_server
@@ -164,6 +169,7 @@ st_server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING