summaryrefslogtreecommitdiff
path: root/TAO/examples/AMH/Sink_Server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/AMH/Sink_Server/Makefile.am')
-rw-r--r--TAO/examples/AMH/Sink_Server/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/TAO/examples/AMH/Sink_Server/Makefile.am b/TAO/examples/AMH/Sink_Server/Makefile.am
index b0fc8e044ff..47839048224 100644
--- a/TAO/examples/AMH/Sink_Server/Makefile.am
+++ b/TAO/examples/AMH/Sink_Server/Makefile.am
@@ -12,6 +12,7 @@ ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
@@ -46,7 +47,7 @@ CLEANFILES += \
TestC.cpp TestC.h TestC.inl TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
-Test-stamp: $(srcdir)/Test.idl
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GH $(srcdir)/Test.idl
@touch $@
@@ -111,7 +112,7 @@ CLEANFILES += \
TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
-Test-stamp: $(srcdir)/Test.idl
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GH $(srcdir)/Test.idl
@touch $@
@@ -184,7 +185,7 @@ CLEANFILES += \
TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
-Test-stamp: $(srcdir)/Test.idl
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GH $(srcdir)/Test.idl
@touch $@