summaryrefslogtreecommitdiff
path: root/TAO/examples/Callback_Quoter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Callback_Quoter/Makefile.am')
-rw-r--r--TAO/examples/Callback_Quoter/Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/TAO/examples/Callback_Quoter/Makefile.am b/TAO/examples/Callback_Quoter/Makefile.am
index 0aeaac91981..b43f75b062d 100644
--- a/TAO/examples/Callback_Quoter/Makefile.am
+++ b/TAO/examples/Callback_Quoter/Makefile.am
@@ -13,11 +13,9 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
## Makefile.Callback_Quoter_IDL.am
BUILT_SOURCES = \
@@ -66,15 +64,14 @@ Notifier-stamp: $(srcdir)/Notifier.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Notifier.idl
@touch $@
+
noinst_HEADERS = \
Consumer.idl \
Notifier.idl
## Makefile.Callback_Quoter_consumer.am
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += consumer
+noinst_PROGRAMS = consumer
consumer_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -105,12 +102,8 @@ consumer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.Callback_Quoter_notifier.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += notifier
notifier_CPPFLAGS = \
@@ -141,12 +134,8 @@ notifier_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.Callback_Quoter_supplier.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += supplier
supplier_CPPFLAGS = \
@@ -176,8 +165,6 @@ supplier_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*