summaryrefslogtreecommitdiff
path: root/TAO/examples/Logging/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Logging/Makefile.am')
-rw-r--r--TAO/examples/Logging/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/TAO/examples/Logging/Makefile.am b/TAO/examples/Logging/Makefile.am
index b0918f2ea0c..e1364b58ef0 100644
--- a/TAO/examples/Logging/Makefile.am
+++ b/TAO/examples/Logging/Makefile.am
@@ -13,11 +13,9 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
## Makefile.Logging_IDL.am
BUILT_SOURCES = \
@@ -43,14 +41,13 @@ Logger-stamp: $(srcdir)/Logger.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Logger.idl
@touch $@
+
noinst_HEADERS = \
Logger.idl
## Makefile.Logging_Service.am
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += Logging_Service
+noinst_PROGRAMS = Logging_Service
Logging_Service_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -79,12 +76,8 @@ Logging_Service_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.Logging_Test.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += Logging_Test
Logging_Test_CPPFLAGS = \
@@ -112,8 +105,6 @@ Logging_Test_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*