summaryrefslogtreecommitdiff
path: root/TAO/examples/POA/Default_Servant/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/POA/Default_Servant/Makefile.am')
-rw-r--r--TAO/examples/POA/Default_Servant/Makefile.am62
1 files changed, 47 insertions, 15 deletions
diff --git a/TAO/examples/POA/Default_Servant/Makefile.am b/TAO/examples/POA/Default_Servant/Makefile.am
index 90541d8e5bc..9a72843cfc9 100644
--- a/TAO/examples/POA/Default_Servant/Makefile.am
+++ b/TAO/examples/POA/Default_Servant/Makefile.am
@@ -16,47 +16,41 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.POA_Default_Servant_IDL.am
+## Makefile.POA_Default_Servant_Client.am
+
+if !BUILD_MINIMUM_CORBA
-BUILT_SOURCES = \
+BUILT_SOURCES += \
FileC.cpp \
FileC.h \
FileC.inl \
- FileS.cpp \
FileS.h \
FileS.inl \
FileS_T.cpp \
FileS_T.h \
FileS_T.inl
-CLEANFILES = \
+CLEANFILES += \
File-stamp \
FileC.cpp \
FileC.h \
FileC.inl \
- FileS.cpp \
FileS.h \
FileS.inl \
FileS_T.cpp \
FileS_T.h \
FileS_T.inl
-FileC.cpp FileC.h FileC.inl FileS.cpp FileS.h FileS.inl FileS_T.cpp FileS_T.h FileS_T.inl: File-stamp
+FileC.cpp FileC.h FileC.inl FileS.h FileS.inl FileS_T.cpp FileS_T.h FileS_T.inl: File-stamp
File-stamp: $(srcdir)/File.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/File.idl
@touch $@
-
-noinst_HEADERS = \
- File.idl
-
-## Makefile.POA_Default_Servant_Client.am
-
-if !BUILD_MINIMUM_CORBA
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -68,7 +62,11 @@ client_CPPFLAGS = \
client_SOURCES = \
FileC.cpp \
client.cpp \
- File_i.h
+ FileC.h \
+ FileC.inl \
+ FileS.h \
+ FileS_T.h \
+ FileS_T.inl
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
@@ -81,6 +79,35 @@ endif !BUILD_MINIMUM_CORBA
if !BUILD_MINIMUM_CORBA
+BUILT_SOURCES += \
+ FileC.cpp \
+ FileC.h \
+ FileC.inl \
+ FileS.cpp \
+ FileS.h \
+ FileS.inl \
+ FileS_T.cpp \
+ FileS_T.h \
+ FileS_T.inl
+
+CLEANFILES += \
+ File-stamp \
+ FileC.cpp \
+ FileC.h \
+ FileC.inl \
+ FileS.cpp \
+ FileS.h \
+ FileS.inl \
+ FileS_T.cpp \
+ FileS_T.h \
+ FileS_T.inl
+
+FileC.cpp FileC.h FileC.inl FileS.cpp FileS.h FileS.inl FileS_T.cpp FileS_T.h FileS_T.inl: File-stamp
+
+File-stamp: $(srcdir)/File.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/File.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -94,6 +121,11 @@ server_SOURCES = \
FileS.cpp \
File_i.cpp \
server.cpp \
+ FileC.h \
+ FileC.inl \
+ FileS.h \
+ FileS_T.h \
+ FileS_T.inl \
File_i.h
server_LDADD = \