summaryrefslogtreecommitdiff
path: root/TAO/examples/POA/Generic_Servant/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/POA/Generic_Servant/Makefile.am')
-rw-r--r--TAO/examples/POA/Generic_Servant/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/TAO/examples/POA/Generic_Servant/Makefile.am b/TAO/examples/POA/Generic_Servant/Makefile.am
index fe173975d57..4d82b4af0b7 100644
--- a/TAO/examples/POA/Generic_Servant/Makefile.am
+++ b/TAO/examples/POA/Generic_Servant/Makefile.am
@@ -13,13 +13,13 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
## Makefile.POA_Generic_Servant_Lib.am
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
BUILT_SOURCES = \
testC.cpp \
@@ -66,12 +66,12 @@ noinst_HEADERS = \
testS.inl \
test_i.h
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
## Makefile.POA_Generic_Servant_Client.am
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS = client
@@ -93,8 +93,8 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.
clean-local: