summaryrefslogtreecommitdiff
path: root/TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am')
-rw-r--r--TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am b/TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am
index 4ed0a438f46..8a3b94450fe 100644
--- a/TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am
+++ b/TAO/examples/PluggableUDP/tests/SimplePerformance/Makefile.am
@@ -50,6 +50,7 @@ noinst_HEADERS = \
## Makefile.SimplePerformance_Client.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -71,11 +72,13 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Makefile.SimplePerformance_Server.am
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -99,6 +102,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.