summaryrefslogtreecommitdiff
path: root/TAO/examples/Quoter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Quoter/Makefile.am')
-rw-r--r--TAO/examples/Quoter/Makefile.am132
1 files changed, 118 insertions, 14 deletions
diff --git a/TAO/examples/Quoter/Makefile.am b/TAO/examples/Quoter/Makefile.am
index 38f86a3ae0c..36ca9402333 100644
--- a/TAO/examples/Quoter/Makefile.am
+++ b/TAO/examples/Quoter/Makefile.am
@@ -16,11 +16,15 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.Quoter_IDL.am
+## Makefile.Quoter_Client.am
+
+if !BUILD_MINIMUM_CORBA
-BUILT_SOURCES = \
+BUILT_SOURCES += \
QuoterC.cpp \
QuoterC.h \
QuoterC.inl \
@@ -31,7 +35,7 @@ BUILT_SOURCES = \
QuoterS_T.h \
QuoterS_T.inl
-CLEANFILES = \
+CLEANFILES += \
Quoter-stamp \
QuoterC.cpp \
QuoterC.h \
@@ -46,17 +50,9 @@ CLEANFILES = \
QuoterC.cpp QuoterC.h QuoterC.inl QuoterS.cpp QuoterS.h QuoterS.inl QuoterS_T.cpp QuoterS_T.h QuoterS_T.inl: Quoter-stamp
Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Quoter.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Quoter.idl
@touch $@
-
-noinst_HEADERS = \
- Quoter.idl
-
-## Makefile.Quoter_Client.am
-
-if !BUILD_MINIMUM_CORBA
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -69,7 +65,13 @@ client_CPPFLAGS = \
client_SOURCES = \
QuoterC.cpp \
+ QuoterS.cpp \
client.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.h \
+ QuoterS_T.h \
+ QuoterS_T.inl \
client.h
client_LDADD = \
@@ -86,6 +88,35 @@ endif !BUILD_MINIMUM_CORBA
if !BUILD_MINIMUM_CORBA
+BUILT_SOURCES += \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+CLEANFILES += \
+ Quoter-stamp \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+QuoterC.cpp QuoterC.h QuoterC.inl QuoterS.cpp QuoterS.h QuoterS.inl QuoterS_T.cpp QuoterS_T.h QuoterS_T.inl: Quoter-stamp
+
+Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Quoter.idl
+ @touch $@
+
noinst_PROGRAMS += Factory_Finder
Factory_Finder_CPPFLAGS = \
@@ -102,7 +133,12 @@ Factory_Finder_SOURCES = \
QuoterC.cpp \
QuoterS.cpp \
Factory_Finder.h \
- Factory_Finder_i.h
+ Factory_Finder_i.h \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.h \
+ QuoterS_T.h \
+ QuoterS_T.inl
Factory_Finder_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Utils.la \
@@ -121,6 +157,35 @@ endif !BUILD_MINIMUM_CORBA
if !BUILD_MINIMUM_CORBA
+BUILT_SOURCES += \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+CLEANFILES += \
+ Quoter-stamp \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+QuoterC.cpp QuoterC.h QuoterC.inl QuoterS.cpp QuoterS.h QuoterS.inl QuoterS_T.cpp QuoterS_T.h QuoterS_T.inl: Quoter-stamp
+
+Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Quoter.idl
+ @touch $@
+
noinst_PROGRAMS += Generic_Factory
Generic_Factory_CPPFLAGS = \
@@ -137,7 +202,12 @@ Generic_Factory_SOURCES = \
QuoterC.cpp \
QuoterS.cpp \
Generic_Factory.h \
- Generic_Factory_i.h
+ Generic_Factory_i.h \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.h \
+ QuoterS_T.h \
+ QuoterS_T.inl
Generic_Factory_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Utils.la \
@@ -156,6 +226,35 @@ endif !BUILD_MINIMUM_CORBA
if !BUILD_MINIMUM_CORBA
+BUILT_SOURCES += \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+CLEANFILES += \
+ Quoter-stamp \
+ QuoterC.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.cpp \
+ QuoterS.h \
+ QuoterS.inl \
+ QuoterS_T.cpp \
+ QuoterS_T.h \
+ QuoterS_T.inl
+
+QuoterC.cpp QuoterC.h QuoterC.inl QuoterS.cpp QuoterS.h QuoterS.inl QuoterS_T.cpp QuoterS_T.h QuoterS_T.inl: Quoter-stamp
+
+Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Quoter.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -171,6 +270,11 @@ server_SOURCES = \
QuoterS.cpp \
Quoter_i.cpp \
server.cpp \
+ QuoterC.h \
+ QuoterC.inl \
+ QuoterS.h \
+ QuoterS_T.h \
+ QuoterS_T.inl \
Quoter_i.h \
server.h