summaryrefslogtreecommitdiff
path: root/TAO/examples/mfc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/mfc/Makefile.am')
-rw-r--r--TAO/examples/mfc/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/TAO/examples/mfc/Makefile.am b/TAO/examples/mfc/Makefile.am
index 66fd3a7554b..329cfb4872b 100644
--- a/TAO/examples/mfc/Makefile.am
+++ b/TAO/examples/mfc/Makefile.am
@@ -26,7 +26,10 @@ BUILT_SOURCES = \
w32_testC.h \
w32_testC.inl \
w32_testS.h \
- w32_testS.inl
+ w32_testS.inl \
+ w32_testS_T.cpp \
+ w32_testS_T.h \
+ w32_testS_T.inl
CLEANFILES = \
w32_test-stamp \
@@ -34,12 +37,15 @@ CLEANFILES = \
w32_testC.h \
w32_testC.inl \
w32_testS.h \
- w32_testS.inl
+ w32_testS.inl \
+ w32_testS_T.cpp \
+ w32_testS_T.h \
+ w32_testS_T.inl
-w32_testC.cpp w32_testC.h w32_testC.inl w32_testS.h w32_testS.inl: w32_test-stamp
+w32_testC.cpp w32_testC.h w32_testC.inl w32_testS.h w32_testS.inl w32_testS_T.cpp w32_testS_T.h w32_testS_T.inl: w32_test-stamp
w32_test-stamp: $(srcdir)/w32_test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -Wb,pch_include=StdAfx.h $(srcdir)/w32_test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT -Wb,pch_include=StdAfx.h $(srcdir)/w32_test.idl
@touch $@
noinst_PROGRAMS = client
@@ -58,7 +64,9 @@ client_SOURCES = \
w32_testC.h \
w32_testC.inl \
w32_testS.h \
- w32_testS.inl
+ w32_testS.inl \
+ w32_testS_T.h \
+ w32_testS_T.inl
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \