summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am28
1 files changed, 22 insertions, 6 deletions
diff --git a/TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am b/TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am
index d46fcdc9e68..da19a54987c 100644
--- a/TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am
+++ b/TAO/orbsvcs/FTRT_Event_Service/Gateway_Service/Makefile.am
@@ -1,16 +1,28 @@
## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-config3/MPC/config -include /home/jtc/ACE/ACE-config3/MPC/templates -type automake TAO.mwc
-ACE_ROOT = $(top_srcdir)/..
ACE_BUILDDIR = $(top_builddir)/..
-TAO_ROOT = $(top_srcdir)
+ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
-## Makefile.FTRTEC_Gateway_Service.am
+## Makefile.FTRTEC_Gateway_Service.am
if BUILD_ACE_UUID
+if BUILD_CORBA_MESSAGING
+if BUILD_INTERCEPTORS
if !BUILD_MINIMUM_CORBA
-noinst_PROGRAMS = ftrtec_gateway_service
+noinst_PROGRAMS += ftrtec_gateway_service
ftrtec_gateway_service_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -40,10 +52,14 @@ ftrtec_gateway_service_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_INTERCEPTORS
+endif BUILD_CORBA_MESSAGING
endif BUILD_ACE_UUID
## Clean up template repositories, etc.
clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
-rm -rf ptrepository SunWS_cache Templates.DB