summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Logging_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Logging_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/Logging_Service/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/TAO/orbsvcs/Logging_Service/Makefile.am b/TAO/orbsvcs/Logging_Service/Makefile.am
new file mode 100644
index 00000000000..93e3437fbb5
--- /dev/null
+++ b/TAO/orbsvcs/Logging_Service/Makefile.am
@@ -0,0 +1,37 @@
+##---------------------------------------------------------------------------
+## $Id$
+##
+## Makefile for TAO's Logging Service
+##
+##---------------------------------------------------------------------------
+
+##
+## Process this file with automake to create Makefile.in
+##
+
+## The number in AUTOMAKE_OPTIONS is the minimum required version automake
+## needed to process this file.
+AUTOMAKE_OPTIONS = 1.4
+
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+
+bin_PROGRAMS = Logging_Service
+
+Logging_Service_LDADD = \
+ $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+
+Logging_Service_SOURCES = \
+ Logging_Service.cpp \
+ Logging_Service_i.cpp
+
+noinst_HEADERS = \
+ Logging_Service_i.h
+
+## EXTRA_DIST = README
+
+## Clean up some additional files/directories possibly created during
+## the configure script tests.
+clean-local:
+ -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
+