summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Makefile.am')
-rw-r--r--TAO/orbsvcs/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/TAO/orbsvcs/Makefile.am b/TAO/orbsvcs/Makefile.am
index f079ecca777..94851fb27c9 100644
--- a/TAO/orbsvcs/Makefile.am
+++ b/TAO/orbsvcs/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
SUBDIRS = \
TAO_Service \
@@ -28,8 +28,16 @@ SUBDIRS = \
Event_Service \
Dump_Schedule \
CosEvent_Service \
- Concurrency_Service \
+ Concurrency_Service
+
+if BUILD_TESTS
+SUBDIRS += \
performance-tests \
- tests \
+ tests
+endif
+
+if BUILD_EXAMPLES
+SUBDIRS += \
examples
+endif