summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am')
-rw-r--r--TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am b/TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am
index 1c4870b680c..cdeaf1f73d1 100644
--- a/TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am
+++ b/TAO/orbsvcs/examples/CosEC/TypedSimple/Makefile.am
@@ -29,7 +29,10 @@ BUILT_SOURCES = \
CountryC.inl \
CountryS.cpp \
CountryS.h \
- CountryS.inl
+ CountryS.inl \
+ CountryS_T.cpp \
+ CountryS_T.h \
+ CountryS_T.inl
CLEANFILES = \
Country-stamp \
@@ -38,12 +41,15 @@ CLEANFILES = \
CountryC.inl \
CountryS.cpp \
CountryS.h \
- CountryS.inl
+ CountryS.inl \
+ CountryS_T.cpp \
+ CountryS_T.h \
+ CountryS_T.inl
-CountryC.cpp CountryC.h CountryC.inl CountryS.cpp CountryS.h CountryS.inl: Country-stamp
+CountryC.cpp CountryC.h CountryC.inl CountryS.cpp CountryS.h CountryS.inl CountryS_T.cpp CountryS_T.h CountryS_T.inl: Country-stamp
Country-stamp: $(srcdir)/Country.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Country.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/Country.idl
@touch $@
noinst_PROGRAMS += Consumer
@@ -66,6 +72,8 @@ Consumer_SOURCES = \
CountryC.inl \
CountryS.h \
CountryS.inl \
+ CountryS_T.h \
+ CountryS_T.inl \
Country_i.h
Consumer_LDADD = \