summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am')
-rw-r--r--TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am b/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
index 61e35c2cd04..185294e39ea 100644
--- a/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
+++ b/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
@@ -23,6 +23,7 @@ noinst_PROGRAMS =
if BUILD_AMI
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
BUILT_SOURCES = \
TestC.cpp \
@@ -30,7 +31,10 @@ BUILT_SOURCES = \
TestC.inl \
TestS.cpp \
TestS.h \
- TestS.inl
+ TestS.inl \
+ TestS_T.cpp \
+ TestS_T.h \
+ TestS_T.inl
CLEANFILES = \
Test-stamp \
@@ -39,18 +43,22 @@ CLEANFILES = \
TestC.inl \
TestS.cpp \
TestS.h \
- TestS.inl
+ TestS.inl \
+ TestS_T.cpp \
+ TestS_T.h \
+ TestS_T.inl
-TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/Test.idl
@touch $@
noinst_HEADERS = \
Test.idl
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI