summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am b/TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am
index 01ff3e4365d..2e8d0086aa8 100644
--- a/TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am
+++ b/TAO/orbsvcs/tests/BiDir_CORBALOC/Makefile.am
@@ -27,7 +27,10 @@ BUILT_SOURCES = \
TimeModuleC.inl \
TimeModuleS.cpp \
TimeModuleS.h \
- TimeModuleS.inl
+ TimeModuleS.inl \
+ TimeModuleS_T.cpp \
+ TimeModuleS_T.h \
+ TimeModuleS_T.inl
CLEANFILES = \
TimeModule-stamp \
@@ -36,12 +39,15 @@ CLEANFILES = \
TimeModuleC.inl \
TimeModuleS.cpp \
TimeModuleS.h \
- TimeModuleS.inl
+ TimeModuleS.inl \
+ TimeModuleS_T.cpp \
+ TimeModuleS_T.h \
+ TimeModuleS_T.inl
-TimeModuleC.cpp TimeModuleC.h TimeModuleC.inl TimeModuleS.cpp TimeModuleS.h TimeModuleS.inl: TimeModule-stamp
+TimeModuleC.cpp TimeModuleC.h TimeModuleC.inl TimeModuleS.cpp TimeModuleS.h TimeModuleS.inl TimeModuleS_T.cpp TimeModuleS_T.h TimeModuleS_T.inl: TimeModule-stamp
TimeModule-stamp: $(srcdir)/TimeModule.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/TimeModule.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/TimeModule.idl
@touch $@
noinst_PROGRAMS = TimeServer
@@ -61,7 +67,9 @@ TimeServer_SOURCES = \
TimeModuleC.h \
TimeModuleC.inl \
TimeModuleS.h \
- TimeModuleS.inl
+ TimeModuleS.inl \
+ TimeModuleS_T.h \
+ TimeModuleS_T.inl
TimeServer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Utils.la \