summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am62
1 files changed, 32 insertions, 30 deletions
diff --git a/TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am b/TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am
index a1c8da1a0f0..025bfa75d32 100644
--- a/TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am
+++ b/TAO/orbsvcs/tests/Bug_1395_Regression/Makefile.am
@@ -1,40 +1,53 @@
## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-config3/MPC/config -include /home/jtc/ACE/ACE-config3/MPC/templates -type automake -noreldefs TAO.mwc
-ACE_ROOT = $(top_srcdir)/..
ACE_BUILDDIR = $(top_builddir)/..
-TAO_ROOT = $(top_srcdir)
+ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(top_builddir)/TAO_IDL/tao_idl
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+## Makefile.Bug_1395_Regression_IDL.am
+
BUILT_SOURCES = \
- TestS_T.cpp \
TestC.cpp \
TestC.h \
- TestS.h \
- TestS_T.h \
TestC.inl \
+ TestS.cpp \
+ TestS.h \
TestS.inl \
+ TestS_T.cpp \
+ TestS_T.h \
TestS_T.inl
CLEANFILES = \
- TestS_T.cpp \
+ Test-stamp \
TestC.cpp \
TestC.h \
- TestS.h \
- TestS_T.h \
TestC.inl \
+ TestS.cpp \
+ TestS.h \
TestS.inl \
- TestS_T.inl \
- Test-stamp
+ TestS_T.cpp \
+ TestS_T.h \
+ TestS_T.inl
-TestS_T.cpp TestC.cpp TestC.h TestS.h TestS_T.h TestC.inl TestS.inl TestS_T.inl: Test-stamp
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
Test-stamp: $(srcdir)/Test.idl
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
@touch $@
+
## Makefile.Bug_1395_Regression_Client.am
noinst_PROGRAMS = client
@@ -48,16 +61,12 @@ client_CPPFLAGS = \
client_SOURCES = \
TestC.cpp \
client.cpp \
- TestC.h \
- TestS_T.h \
- TestC.inl \
- TestS_T.inl
+ Test_i.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-
## Makefile.Bug_1395_Regression_Server.am
noinst_PROGRAMS += server
@@ -73,26 +82,19 @@ server_SOURCES = \
TestS.cpp \
Test_i.cpp \
server.cpp \
- TestC.h \
- TestS.h \
- TestS_T.h \
- Test_i.h \
- TestC.inl \
- TestS.inl \
- TestS_T.inl
+ Test_i.h
server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_ImR_Client.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
- $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-
## Clean up template repositories, etc.
clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
-rm -rf ptrepository SunWS_cache Templates.DB