summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am b/TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am
index 06f10909d11..cc54d21323c 100644
--- a/TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am
+++ b/TAO/orbsvcs/tests/Bug_2377_Regression/Makefile.am
@@ -28,7 +28,10 @@ BUILT_SOURCES = \
HelloC.inl \
HelloS.cpp \
HelloS.h \
- HelloS.inl
+ HelloS.inl \
+ HelloS_T.cpp \
+ HelloS_T.h \
+ HelloS_T.inl
CLEANFILES = \
Hello-stamp \
@@ -37,12 +40,15 @@ CLEANFILES = \
HelloC.inl \
HelloS.cpp \
HelloS.h \
- HelloS.inl
+ HelloS.inl \
+ HelloS_T.cpp \
+ HelloS_T.h \
+ HelloS_T.inl
-HelloC.cpp HelloC.h HelloC.inl HelloS.cpp HelloS.h HelloS.inl: Hello-stamp
+HelloC.cpp HelloC.h HelloC.inl HelloS.cpp HelloS.h HelloS.inl HelloS_T.cpp HelloS_T.h HelloS_T.inl: Hello-stamp
Hello-stamp: $(srcdir)/Hello.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Hello.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/Hello.idl
@touch $@
noinst_PROGRAMS = uipmc_test
@@ -62,7 +68,9 @@ uipmc_test_SOURCES = \
HelloC.h \
HelloC.inl \
HelloS.h \
- HelloS.inl
+ HelloS.inl \
+ HelloS_T.h \
+ HelloS_T.inl
uipmc_test_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_PortableGroup.la \