summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Blocking/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Blocking/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Blocking/Makefile.am28
1 files changed, 5 insertions, 23 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Blocking/Makefile.am b/TAO/orbsvcs/tests/Notify/Blocking/Makefile.am
index c14da3f82da..099a4a73ecd 100644
--- a/TAO/orbsvcs/tests/Notify/Blocking/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/Blocking/Makefile.am
@@ -50,12 +50,8 @@ go-stamp: $(srcdir)/go.idl $(TAO_IDL_DEP)
@touch $@
-noinst_HEADERS = \
- go.idl
-
## Makefile.Blocking_Ntf_Struct_Cons.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Consumer
@@ -73,18 +69,13 @@ Structured_Consumer_CPPFLAGS = \
Structured_Consumer_SOURCES = \
Notify_Structured_Push_Consumer.cpp \
Structured_Consumer.cpp \
+ common.cpp \
goC.cpp \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -100,11 +91,9 @@ Structured_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Blocking_Ntf_Struct_Supp.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Supplier
@@ -123,17 +112,11 @@ Structured_Supplier_SOURCES = \
Structured_Supplier.cpp \
goC.cpp \
goS.cpp \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -149,7 +132,6 @@ Structured_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: