summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Discarding/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Discarding/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Discarding/Makefile.am53
1 files changed, 10 insertions, 43 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Discarding/Makefile.am b/TAO/orbsvcs/tests/Notify/Discarding/Makefile.am
index a40b3ce1e16..eaac6e439f2 100644
--- a/TAO/orbsvcs/tests/Notify/Discarding/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/Discarding/Makefile.am
@@ -50,12 +50,8 @@ go-stamp: $(srcdir)/go.idl $(TAO_IDL_DEP)
@touch $@
-noinst_HEADERS = \
- go.idl
-
## Makefile.Discarding_Ntf_Seq_Cons.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Consumer
@@ -73,18 +69,13 @@ Sequence_Consumer_CPPFLAGS = \
Sequence_Consumer_SOURCES = \
Notify_Sequence_Push_Consumer.cpp \
Sequence_Consumer.cpp \
+ common.cpp \
goC.cpp \
- Notify_Sequence_Push_Consumer.h
+ Notify_Sequence_Push_Consumer.h \
+ common.h
Sequence_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -100,11 +91,9 @@ Sequence_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Discarding_Ntf_Seq_Supp.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Supplier
@@ -124,17 +113,11 @@ Sequence_Supplier_SOURCES = \
goC.cpp \
goS.cpp \
Notify_Sequence_Push_Consumer.h \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Sequence_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -150,11 +133,9 @@ Sequence_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Discarding_Ntf_Struct_Cons.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Consumer
@@ -172,18 +153,13 @@ Structured_Consumer_CPPFLAGS = \
Structured_Consumer_SOURCES = \
Notify_Structured_Push_Consumer.cpp \
Structured_Consumer.cpp \
+ common.cpp \
goC.cpp \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -199,11 +175,9 @@ Structured_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Discarding_Ntf_Struct_Supp.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Supplier
@@ -223,17 +197,11 @@ Structured_Supplier_SOURCES = \
goC.cpp \
goS.cpp \
Notify_Sequence_Push_Consumer.h \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -249,7 +217,6 @@ Structured_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: