summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am53
1 files changed, 10 insertions, 43 deletions
diff --git a/TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am b/TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am
index 47360ae1d2c..86c5c6c75e1 100644
--- a/TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/performance-tests/Filter/Makefile.am
@@ -52,14 +52,10 @@ go-stamp: $(srcdir)/go.idl $(TAO_IDL_DEP)
@touch $@
-noinst_HEADERS = \
- go.idl
-
endif !BUILD_MINIMUM_CORBA
## Makefile.Filter_Notify_Perf_Sequence_Consumer.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Consumer
@@ -77,18 +73,13 @@ Sequence_Consumer_CPPFLAGS = \
Sequence_Consumer_SOURCES = \
Notify_Sequence_Push_Consumer.cpp \
Sequence_Consumer.cpp \
+ common.cpp \
goC.cpp \
- Notify_Sequence_Push_Consumer.h
+ Notify_Sequence_Push_Consumer.h \
+ common.h
Sequence_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -104,11 +95,9 @@ Sequence_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Filter_Ntf_Perf_Seq_Supp.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Supplier
@@ -128,17 +117,11 @@ Sequence_Supplier_SOURCES = \
goC.cpp \
goS.cpp \
Notify_Sequence_Push_Consumer.h \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Sequence_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -154,11 +137,9 @@ Sequence_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Filter_Ntf_Perf_Struct_Cons.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Consumer
@@ -176,18 +157,13 @@ Structured_Consumer_CPPFLAGS = \
Structured_Consumer_SOURCES = \
Notify_Structured_Push_Consumer.cpp \
Structured_Consumer.cpp \
+ common.cpp \
goC.cpp \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -203,11 +179,9 @@ Structured_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Makefile.Filter_Ntf_Perf_Struct_Supp.am
-if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Structured_Supplier
@@ -227,17 +201,11 @@ Structured_Supplier_SOURCES = \
goC.cpp \
goS.cpp \
Notify_Sequence_Push_Consumer.h \
- Notify_Structured_Push_Consumer.h
+ Notify_Structured_Push_Consumer.h \
+ common.h
Structured_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
- $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -253,7 +221,6 @@ Structured_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: