summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Simple_Naming/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Simple_Naming/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Simple_Naming/Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/TAO/orbsvcs/tests/Simple_Naming/Makefile.am b/TAO/orbsvcs/tests/Simple_Naming/Makefile.am
index 0533da6d515..01c8adb2ce2 100644
--- a/TAO/orbsvcs/tests/Simple_Naming/Makefile.am
+++ b/TAO/orbsvcs/tests/Simple_Naming/Makefile.am
@@ -13,21 +13,21 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-
## Makefile.Simple_Naming_Client.am
-if BUILD_EXCEPTIONS
-
BUILT_SOURCES = \
test_objectC.cpp \
test_objectC.h \
test_objectC.inl \
test_objectS.cpp \
test_objectS.h \
- test_objectS.inl
+ test_objectS.inl \
+ test_objectS_T.cpp \
+ test_objectS_T.h \
+ test_objectS_T.inl
CLEANFILES = \
test_object-stamp \
@@ -36,12 +36,15 @@ CLEANFILES = \
test_objectC.inl \
test_objectS.cpp \
test_objectS.h \
- test_objectS.inl
+ test_objectS.inl \
+ test_objectS_T.cpp \
+ test_objectS_T.h \
+ test_objectS_T.inl
-test_objectC.cpp test_objectC.h test_objectC.inl test_objectS.cpp test_objectS.h test_objectS.inl: test_object-stamp
+test_objectC.cpp test_objectC.h test_objectC.inl test_objectS.cpp test_objectS.h test_objectS.inl test_objectS_T.cpp test_objectS_T.h test_objectS_T.inl: test_object-stamp
test_object-stamp: $(srcdir)/test_object.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/test_object.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/test_object.idl
@touch $@
noinst_PROGRAMS = client
@@ -62,7 +65,9 @@ client_SOURCES = \
test_objectC.h \
test_objectC.inl \
test_objectS.h \
- test_objectS.inl
+ test_objectS.inl \
+ test_objectS_T.h \
+ test_objectS_T.inl
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Utils.la \
@@ -74,8 +79,6 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*